This may require editing the ivizgroup.properties on your server in the configuration (conf) directory.
Issue:
User exports the required charts and dashboards to an etlarchive.zip or idbarchive.zip on a data source. While importing on a target install from Admin -> System -> Import/Export an Error occurs. Hovering on the Error gives the message:
This chart cannot be imported because the data source with global identifier <id> is not available in the current repository.
Cause:
- A table, view, or named range has changed in the data source
- There could be a table locking issue with the database
- The required JDBC drivers have not been installed
Resolution:
Please try the below steps to resolve the issue:
- Try re-saving the data source in iDashboards Admin and see if this resolves the issue.
- Are the Excel spreadsheet that are being used as the data source currently open?
- If so, then please close all the excel spreadsheets and try again
- Are you trying to connect to an Excel spreadsheet on a 64 bit system? The Microsoft ODBC drivers for 64 bit systems are not supported.
- You should uninstall the 64 bit drivers and install the 32 bit drivers instead.
- Try adding the following to the ivizgroup.properties:
- db.validateConnections=true
For More Information: IDashboards Admin Manual 13.8 Importing and Exporting
If the above is unable to resolve the issue, then please contact iDashboards Support for further assistance.
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